[SOLVED]BlackScreen Problem In BackTrack 5 R2 After StartX

BackTrack is a distribution based on the Debian GNU/Linux distribution aimed at penetration testing and digital forensics use. It is named after a search algorithm, backtracking algorithm. The current version is BackTrack 5 R2, codenamed as “Revolution and its Revision”.

After making a live usb boot device or a live cd, when you boot from your backtrack source,it asks you to select a boot mode.When you select a boot mode and after a while there appears a console window in which you type Startx for the graphical user iterface of the BackTrack.But sometimes, the gui does not appear and the screen is completely black. This problem appears many times. I tried various solutions but cannot solve this problem and now finally i have got a solution which i am posting here.

Follow the steps below:-
  •              Boot the live disk.
  •              When the screen comes to select a boot mode(text mode, safe mode,etc) , press the TAB key.     This will open the grub options for the live boot.
  •            Change “text splash vga=791” to “text splash vga=791 i915.modeset=1”. 
  •            Press the Enter key.
  •           Wait till the screen appears to enter startx.
  • ·         Finally you have the GUI of BackTrack.
Hope this helps...
    RefreshIt

[SOLVED]BlackScreen Problem In BackTrack 5 R2 After StartX [SOLVED]BlackScreen Problem In BackTrack 5 R2 After StartX Reviewed by RefreshIt on 9:34:00 AM Rating: 5

15 comments:

  1. It worked!!! :)
    Thanks!

    ReplyDelete
  2. Worked for me too. Thank you very much....!!!!

    ReplyDelete
  3. hi and tanx ... but not worked ... i used this code and it worked :

    "quiet splash i915.modeset=1 vga=791"

    ReplyDelete
  4. Fucking A. After scouring post after post your comment did it. Thanks y'all!

    ReplyDelete
  5. thanks my friend
    "quiet splash i915.modeset=1 vga=791"
    it is working

    ReplyDelete
  6. Normally it works, and thanks all for your comment...

    ReplyDelete
  7. Hi all, I also wanted to say your code works. I was struggling for a long time, but finally after reading your post it worked.

    ""hi and tanx ... but not worked ... i used this code and it worked :

    "quiet splash i915.modeset=1 vga=791" ""

    ReplyDelete
  8. If this doesnt work. Do this as well. Connect your computer to the internet via Ethernet cable. Sudo apt-get update in command line. Then startx. Hope this helps

    ReplyDelete
  9. Is there an ISO of backtrack with this fixed for a live USB stick to run?

    ReplyDelete
  10. Great ! it works

    ReplyDelete
  11. Wow, "quiet splash i915.modeset=1 vga=791" made it. thanks

    ReplyDelete
  12. xforcevesa solves this issue for intel CPU/GPU combo...you can use if irqpoll if you are having issues getting things to register

    ReplyDelete
  13. Thank YOU!!!! - This worked for me, {cd boot overe os with ubuntu 12.4} screw nixie pixel her vids did not help - this did!!

    ReplyDelete
  14. Wow, "quiet splash i915.modeset=1 vga=791"
    thanks HP G62 ati and intel GPU

    ReplyDelete
  15. thank you very very much, it worked

    ReplyDelete

Powered by Blogger.